Dash.notify causes crash

If you are asking a question, please follow this template:

  1. My goal is: Send notifications from device.

  2. My actions are: Enable Dash, works fine, shadow and rpc too
    but if I try this test in js-demo-bundle app…

    let reportState = function() {
       if (Dash.isConnected()) {
         Dash.notify('Data', {level: 9});
  3. The result I see is: Notification is sent, but app crash

Guru Meditation Error: Core 0 panic’ed (InstrFetchProhibited). 00000
PS : 0x00060030 A0 : 0x800faed6 A1 : 0x3ffca790
A2 : 0x3ffb5930 A3 : 0x3ffc7c08 A4 : : 0x00000000 A8 : 0x800fced5 A9 : 0x3ffca780
A10 : 0x3ffb5930 A11 : 0x00000000 A12 : 0x3ffb6360 000 SAR : 0x0000000e EXCCAUSE: 0x00000014
EXCVADDR: 0x0f34a98ed5f0ddb2d6b82c754a46b2c68

Backtrace: 0x00000000 0x400f1d3e76 0x401d414f 0x401d399a 0x401d4cce 0x401d7eed 0x401d7f1f 0x401eb9fd 0x401cfe21 0x40083826 0x400839ed
— BEGIN CORE DUuild_id" …

  1. My expectation & question is: Please can you help me, thanks in advance

I’m trying to walk in core dump, but dash is closed library, therefore I don’t expect to get too much progress.

Sorry, I forgot to mention, I am using esp32-PICO-KIT with mongoose-os, I have tried with free and licensed software

I had a very similar problem, although mine seemed to be specific to changing the file system size. The workaround was to use single core mode, you may want to try that.

See here:


Hi Jim,
First of all, thank you very much for your reply.
I have tried FREERTOS_UNICORE=y and it still doesn’t work, I think my problem is different since I can connect to mDash without problems, only Dash.notify fails.
I’ll post a question in the mDash forum too.
Thanks Jim

Okay, sorry that didn’t help. If you find a resolution please post it here, thanks and good luck!