Demo app doesn`t work on esp8266 on latest version

#1

I’m trying to use mongoose OS for the first time, I am following the quick start guide and having a lot of issues. At first ctrl-n to create new app didn’t work because it opens a new browser tab, so I used the
mos clone https://github.com/mongoose-os-apps/demo-js app1 command manually and it didn’t work, I updated mos tool to latest version and this resolved this issue. Build worked fine but after flashing I keep getting exception 9 errors and the mos wifi command doesn’t work. I tried using windows 10 and ubuntu and had the same issue on both. I managed to get it working by downgrading mos to 2.18.0.

#2

“it didn’t work” would probably mean that you got an old version that had an issue that has already been fixed, which is hard to tell because you don’t say which version nor which error you got. I seem to remember there was some version that had an issue with cloning, you can always use git to clone, though if you are in the W world you probably don’t have git around git clone url
“exception 9 errors”: I’m a lazy old guy with a bad memory, I don’t remember what those are; but if you add the logs perhaps someone can guide you.
Many ESP8266 boards do not have enough memory to run the latest flavors, some people get an “app too big” error. Others do not correctly specify the flash parameters (sometimes you have to, it happened to me).
"mos wifi does not work: mos wifi should work if you pass the parameters as you should, or if it doesn’t work for you, and you post exactly what you try and what doesn’t work for you, perhaps someone might help. Or, if it really is an issue, someone might even write a pull request for it to be fixed. Hard to tell when there is no description of the problem.
Last time I used it, it worked just fine, though I don’t use it on a regular basis
mos config-set wifi

#3

It looks like there are some issues with the latest mjs library/module.
I don’t use it, so I won’t investigate…