MQTT0 TCP connect ok (0)/Disconnect

#1

I have updated MOS tool (windows) to release channel. I have tried to build the FW but now the mDash MQTT keeps disconnecting after connecting:

[Feb 26 14:39:09.600] Offline for:26 
[Feb 26 14:39:14.473] mgos_mqtt_conn.c:467    MQTT0 connecting to mdash.net:8883
[Feb 26 14:39:14.473] mg_net.c:911            0x3ffd3128 mdash.net:8883 -,-,-
[Feb 26 14:39:14.493] mg_net.c:911            0x3ffcc7cc udp://8.8.8.8:53 -,-,-
[Feb 26 14:39:14.493] mg_net.c:779            0x3ffcc7cc udp://8.8.8.8:53
[Feb 26 14:39:14.493] mg_net.c:794            0x3ffcc7cc udp://8.8.8.8:53 -> 0
[Feb 26 14:39:14.632] mg_net.c:779            0x3ffd3128 tcp://148.251.54.236:8883
[Feb 26 14:39:14.918] mg_net.c:794            0x3ffd3128 tcp://148.251.54.236:8883 -> 0
[Feb 26 14:39:14.918] mgos_mqtt_conn.c:227    MQTT0 TCP connect ok (0)
[Feb 26 14:39:15.200] mgos_mqtt_conn.c:253    MQTT0 Disconnect
[Feb 26 14:39:15.200] CLOUD_DISCONNECTED 
[Feb 26 14:39:15.288] mgos_event.c:135        ev MOS5 triggered 1 handlers
[Feb 26 14:39:15.288] mgos_mqtt_conn.c:543    MQTT0 connecting after 14786 ms
[Feb 26 14:39:19.601] Offline for:36 

Also, when building it tells me:

WARNING: the lib "captive-portal-wifi-web" does not have version 2.17.0. Resorting to latest, but the build might fail.
It usually happens if you clone the latest version of some example app, and try to build it with the mos tool which is older than the lib (in this case, "captive-portal-wifi-web").

And finally Dash.notify in MJS is still not working, since I made the last Pull Request on Oct/2019

#2

How do you provision the dash and mqtt libraries? AFAIK, you can’t use dash with both mqtt and wss protocols.

captive-portal-wifi-web is a contributed Mongoose OS library which doesn’t belong to mongoose-os-libs and doesn’t have a release (2.17.0) version. The message you see is just a warning, it doesn’t affect the way it works.

#3

Thanks,
Something got screwup in mos.yml with mqtt.enable parameter (was commented originally).

Any news on en Dash.notify problem?. Trying to write to the mdash DB.Save topic with this, but no luck