Revert to older mos version

#1

I am wanting to revert to an older version of Mongoose OS. Currently I am using 2.19.1, but I am looking to use 2.17.0. I previously found a guide to this in the old forum (via this link), but I can’t get to that any longer. I can’t seem to find the information anywhere else either.

I have tried mos update 2.17.0 without success.

#2
libs_version: 2.17.0
modules_version: 2.17.0
mongoose_os_version: 2.17.0
#3

Ok, thanks. I already have these settings. So it doesn’t make any difference what version I have installed on computer as long as I have those rows in mos.yml?

I am trying to make sense of a wifi/core dump error I’m getting and thought it could have to do with my version, since it is different from colleagues who aren’t having wifi errors (and we have previously have core dumps due to versions above 2.17.0). But if this is all that is needed, the error must be due to something else. I’d better write a new question…

#4

Yes. You can check the build.log and you’ll see that the 2.17.0 versions of the libraries and other dependencies are pulled during the build process.