Access Denied on COM Port for CC3200

#1

If you are asking a question, please follow this template:

  1. My goal is: Connect MOS to CC3200 device and trigger data to GCP IoT Cloud
  2. My actions are: I am facing similar issue on windows 10, just brought cc3200 device to learn and experiment but its been 3 days no sucess in connecting device, I thought it was seemless integration with this new MONGO OS , not looks like its EFFORT, not impressive at all in first glance. Getting access denied on all COM ports, tried almost all changing COM1,2,34,5…not working at all… 10 times restarted systems.
  3. The result I see is: Pls see below screenshot
  4. My expectation & question is: How to connect seamlessly to Mongoose OS, I am getting access Denied issue all time.

#2

Check to see if you have another putty or similar connection open on com2. If none open, open task manager and end all tasks/processes for mos.exe.
Then retry mos on com2.

#3

Thanks. I am able to connect to COM7 port with Uniflash software of Texas instrument and tried after 10-15 attempts on my system, I was able to see MOS woke up and connected to COM7 port, but when I tried to run ctrl+i or any command, it simply says denied. Documentation is so poor by MOS, need to hire right ppl

#4

Make sure that you are not trying to connect mos to com7 while uniflash is also connected to com7.

#6

I was able to connect it but WIFI is still not showing up…after multiple attempts

can’t add device further on mdash.net

image

#7

Bad news!! When I try to run below —
D:\app3>d:\mos build --platform cc3200 and Mongoose Team confirmed this can hold memory.

*** Out of space, tried to write 25586 bytes ***
make: *** [/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/build/objs/spiffs.img] Error 1
make: *** Waiting for unfinished jobs…
/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/deps/modules/mongoose-os/platforms/cc3200/Makefile.build:238: recipe for target ‘/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/build/objs/spiffs.img’ failed
“/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/deps/modules/mongoose-os/platforms/cc3200/ld/cc3200.cmd”, line 24: error #10099-D:
program will not fit into available memory. placement with alignment fails
for section “GROUP_1” size 0x49bbc . Available memory ranges:
SRAM size: 0x40000 unused: 0x3fafc max hole: 0x3fafc
error #10010: errors encountered during linking;
“/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_1335
22072/build/objs/app3.elf” not built

Compilation failure
/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/deps/modules/mongoose-os/platforms/cc3200/Makefile.build:325: recipe for target ‘/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/build/objs/app3.elf’ failed
make: *** [/data/fwbuild-volumes/latest/apps/app3/cc3200/build_contexts/build_ctx_133522072/build/objs/app3.elf] Error 1
make: Leaving directory ‘/app’
Error: exit status 2
/go/src/github.com/mongoose-os/mos/mos/build_local.go:679:
/go/src/github.com/mongoose-os/mos/mos/build_local.go:666:
/go/src/github.com/mongoose-os/mos/mos/build_local.go:431:
/go/src/github.com/mongoose-os/mos/mos/build.go:223:
/go/src/github.com/mongoose-os/mos/mos/build.go:166:
/go/src/github.com/mongoose-os/mos/mos/main.go:196: build failed
Error: /go/src/github.com/mongoose-os/mos/mos/build_remote.go:326: build failed
/go/src/github.com/mongoose-os/mos/mos/build.go:223:
/go/src/github.com/mongoose-os/mos/mos/build.go:166:
/go/src/github.com/mongoose-os/mos/mos/main.go:196: build failed