COM Port Issue on Windows

#1

Hi all,

I’m having an issue with COM ports on Windows 10 Pro. I want to reconnect my ESP8266 but the COM port is no longer showing.

A couple of days ago I started following the quick start guide and completed it without issue. The device was online in mdash. I came back to continue other tutorials today but now I can’t see the COM port in mos. I can only see COM1 and when i press ctrl+i to show device info, it doesn’t allow me. When I disconnect and reconnect the esp8266, I see no changes in COM ports (COM1 is the only option, doesn’t go when I disconnect either). I’ve changed the cable into three different USB slots and nothing is changing.

I went back to the quick start guide and followed steps again, but can’t get past step 3 which is USB-to-Serial drivers.I downloaded the CH43x drivers and CP210x drivers to see if they fixed it. (Just to add, nothing in my setup had changed from when it first worked).

I’m on Windows. it’s possible a Windows update occured which caused an issue, but I can’t be sure.

Has anyone got any suggestions for things I should look at?

Many thanks,

#2

This doesn’t sound like a mos issues. I’d say look generally around on the internet for a solution, then it should be fixed in mos.

I would start looking at Arduino just because there is a lot of info on it.

You should see the device appear and disappear in the windows device manager tool as it plug it in and remove it from the USB port. If that isn’t happening try a different USB cable maybe or if you have another ESP board try that. My only other suggestion would be to maybe try and change the port of the device that is showing up as COM1 to another port number and trying again. I’ve had the issue in the past where the device won’t register because it wants to use a port number already assigned.

#3

Hi @felixbridge
Not sure if my experience is still valid. I stop using window 10 when I got a mac.

In Window 10, automatic update has always cause some problem in VCP driver some years ago.
What I do is to check the driver version of the VCP or UART driver. If you find 2 version in the driver list, select the old version seems to help in my past project.

Also, restarting the PC may cause the driver to always point to the latest version of the VCP that never work for me. After every restart, I have to reselect the older VCP version.

Hope this information is outdated as it is annoying to revert the driver version every time the pc is restart or the window update happens.

#4

Thanks for the help both.

Tried a different USB cable and it worked… can’t believe I didn’t try that before but also can’t believe that was the issue :joy:

#5

I’ve been fooled more times than I care to admit with a charge only USB cable. Glad you worked it out