Error Mos Tool Display

#1

Help Me,

  1. My goal is: [Error Install Mos Tool.exe]
  2. My actions are: [App]
  3. The result I see is: [Failed to lunch Mos Tool.exe]
  4. My expectation & question is: [why is my “Mouse Tool” look like this, what do I need to fix? Help Me. please]

#2

Apparently you’re running some obscure version of Windows , or have some strange Internet Explorer version.

#3

so what should I do, I have updated my windows

#4

Launch command prompt, and in the command prompt, run:

mos --start-webview=false

That will start a UI inside a browser window instead of webview. Don’t forget to kill the command prompt console when done.

#5

I tried with command prompt, but still doesn’t work

#6

Hi,
I installed docker in order to run mos buil locally.
Since I installed Docker I cannot run mos tool anymore.
Double click on mos.exe or ./mos from shell give the same results, a black windows appear for just a moment and then nothing.
If I run mos --start-webview=false I got Error: listen tcp 127.0.0.1:1992: bind: Tentativo di accesso al socket con modalità non consentite dalle rispettive autorizzazioni di accesso. /go/src/github.com/mongoose-os/mos/mos/ui.go:348:
/go/src/github.com/mongoose-os/mos/mos/main.go:196: ui failed
Any help?

Thanks

#7

Which mos version are you using?

#8

Hi Fabio,
Thanks for reply.
I updated to the last version and I tried also to download a new mos.exe file.
Actually I removed Docker too but nothing chenged.

#9

Check if another instance of the mos tool is running. If the answer is yes, kill it and try again.

#10

I checked, I have no other mos instance running.

Thanks

Mongoose os cannot start on windows 10
#12

I solved it.
Installing docker I enabled Hyper-V Features blocking the access to the port used by mos.exe.
In order to disable Hyper-V features, just run:
dism.exe /Online /Disable-Feature:Microsoft-Hyper-V