Install 2.19 on mac os 13.3

  1. My goal is:
    To install mos 2.19.0 on the MacOS 13.3.

  2. My actions are:
    I have tried to install 2.19.0 via brew on MacOS 13.3, but I couldn’t find this version in brew search.

Then I run

brew install

but it doesn’t work, compilation error

./webview.h:2252:16: error: too many arguments to function call, expected 0, have 3
  objc_msgSend(app, sel_registerName("terminate:"), app);

Download GitHub - mongoose-os/mos: The Mongoose OS Command Line Tool - source code, switch to 2.19.0 commit and build doesn’t work too, the same ./webview.h error.

I found that GitHub - webview/webview: Tiny cross-platform webview library for C/C++/Golang. Uses WebKit (Gtk/Cocoa) and Edge (Windows) was removed from dependencies.

  1. Question: how to install 2.19.0 on MacOS 13.3

You don’t need to install 2.19.0. You install mos with brew and you’ll have 2.20.0, then pin the version in mos.yml

libs_version: 2.19.0
modules_version: 2.19.0
mongoose_os_version: 2.19.0

Thank you for your help