Mongoose TLS version

#1

In the official website https://mongoose-os.com/mos.html
It has been given as TLS1.2, mutual TLS.

It means it will support only TLS 1.2 or TLS 1.0.

So it means mongoose in browser TLS 1.3 will not be support any more ?

#2

TLS 1.3 will be supported in the future.

#3

Thanks for the update.

  1. Like to know is their any release date confirm ?
  2. If our application need to support TLS 1.3 in mongoose what will be the procedure to speedup the process or development work in your side?
#4

Depends on who asks. If you’re asking as a non-commercial, community user, then you’re welcome to implement it and thus contribute to the community.
If you’re asking as a commercial entity, please mail to support@cesanta.com