Resetting Adafruit Hazzah32 - ESP32 Feather to factory settings

#1
  1. My goal is: To reset my Adafruit Hazzah32 - ESP32 Feather to factory settings
  2. My actions: I purchased and configured this one account but I now need to change accounts and would like to start from fresh. I am having trouble resetting it though and am not sure how to delete the configuration that I loaded on it. It keeps coming up with “resource busy” messages.

I’m brand new to working with this so please assume little to no knowledge on my part.

Thanks for your help!

#2

Could you be more specific, please?
What do you mean by

  • “I purchased and configured this one account”
  • “I now need to change accounts and would like to start from fresh”
  • “having trouble resetting”
  • “It keeps coming up with “resource busy” messages”?
#3

Hi There

Yes!
I purchased the Mongoose OS IoT starter kit with ESP32 board from Adafruit. This kit has a tutorial that goes through configuring the Adafruit Hazzah32 - ESP32 Feather to talk to Google Cloud IoT Core.

I followed the first 10 steps of this guide which walks through the configuration to the point of enabling wifi, mqtt, mdash OTA, etc. However, I did that on my personal account on a Windows PC.

Since then I was able to get my Macbook Air working and I need to run this project on my Macbook and using my corporate account.

I tried connecting the board to the Macbook (instead of PC) and tried to re-build (mos build) and reflash (mos flash) along with some other options BUT the settings that have been saved persist and I get a message to the effect that the resource is busy (when I try to re-flash, etc.). I can get you the exact message if the above detail is not sufficient.

So I’m trying to get the ESP32 to boot in the same way it did before I did anything to it so I can start fresh.

Please let me know if I should include more detail or specific messages. I’d be happy to do so if needed.

Thanks for helping me out here!!
Dan

#4

More details would be useful.

AFAIK, the resource busy error means the port is already used by another application.
You can run mos ports to list the available serial ports and check if mos is using the right port. On a Mac it should be something like /dev/cu.xxxx

#5

Here’s a screenshot of what I get:

#6

On the Windows PC it was using COM3.

#7

I think I need to pull GPIO 0 low while holding the reset so as to boot from ROM. I’m just not sure how to do that…

The above is from this section of ESP32 Boot Mode Selection:
"## GPIO0

The ESP32 will enter the serial bootloader when GPIO0 is held low on reset. Otherwise it will run the program in flash.

GPIO0 Input Mode
Low/GND ROM serial bootloader for esptool.py
High/VCC Normal execution mode

GPIO0 has an internal pullup resistor, so if it is left unconnected then it will pull high.

Many boards use a button marked “Flash” (or “BOOT” on some Espressif development boards) that pulls GPIO0 low when pressed."

#8

The name of the port suggests bluetooth headphones.

It looks like you don’t have the driver for the USB bridge on the device.
According to Adafruit, the chip is a CP2104.
Download and install the driver from here

#9

You were correct!
When I added the USB driver and changed the port on the MOS tool it allowed me to access it and do what I need.

Thanks so much for your help. Much appreciated!!