Unable to Flash CC3220

#1
  1. My goal is: Flash a CC3220 with the demo code

  2. My actions are: Run mos flash cc3220

  3. The result I see is:

    Uploading UCF image (744416 bytes)
    Error: /go/src/github.com/mongoose-os/mos/mos/flash/cc32xx/rom_client.go:689: image programming error @ 0: e0 = -10275, e1 = 4097
    /go/src/github.com/mongoose-os/mos/mos/flash/cc3220/flasher.go:116: failed to upload image
    /go/src/github.com/mongoose-os/mos/mos/flash.go:223:
    /go/src/github.com/mongoose-os/mos/mos/main.go:196: flash failed

  4. My expectation & question is: Be able to flash it properly.

Is support for the CC3220 still on plate?

#2

Can’t tell if the Demo code is available for CC3220.

try building from the empty app:
mos clone https://github.com/mongoose-os-apps/empty empty_cc3220

Then mos build selecting CC3220 from above or by entering: mos build --platform cc3220

Then try flashing with plain
mos flash

#3

The demo is available because the zip file is downloaded and starts the flash procedure. But it fails in the end. But I will make a new build to see if the product can flash properly. Will update in a bit.

#4

Nothing still!

C:\Users\Juan\Repos\empty>mos build --platform cc3220
Connecting to https://mongoose.cloud, user test
Uploading sources (2465 bytes)
Firmware saved to C:\Users\Juan\Repos\empty\build\fw.zip

C:\Users\Juan\Repos\empty>mos flash --port com6 && mos console
Loaded empty/cc3220 version 1.0 (20190905-131402)
Found BPI binary: c:\ti\uniflash_5.0.0\simplelink\imagecreator\bin\BuildProgrammingImage.exe
Using XDS110 debug probe to control the device...
  XDS110 2.3.0.7 HW 39 S/N E0071009
Opening com6...
Connecting to boot loader..
  CC3220SF boot loader v0.1.0.3, storage 0x86
Switching to NWP...
  NWP boot loader v1.1.0.3, storage 0x84
  MAC: 98:84:e3:f6:78:f7
Applying boot loader patches...
  RAM patch applied, new version: 1.1.0.34
  Flash patch applied
Generating UCF image for 98:84:e3:f6:78:f7 (flash size: 4194304)
Running c:\ti\uniflash_5.0.0\simplelink\imagecreator\bin\BuildProgrammingImage.exe -i C:\Users\Juan\AppData\Local\Temp\empty_cc3220_1.0_358617603 -x C:\Users\Juan\AppData\Local\Temp\empty_cc3220_1.0_358617603\ImageConfig.xml
Uploading UCF image (600528 bytes)
Error: /go/src/github.com/mongoose-os/mos/mos/flash/cc32xx/rom_client.go:689: image programming error @ 0: e0 = -10275, e1 = 4097
/go/src/github.com/mongoose-os/mos/mos/flash/cc3220/flasher.go:116: failed to upload image
/go/src/github.com/mongoose-os/mos/mos/flash.go:223:
/go/src/github.com/mongoose-os/mos/mos/main.go:196: flash failed

It would be great if at least we could use uniflash to flash the result. But I don’t really understand it.

#5

I am having this exact same error. I am using the empty project with the TI cc3220sf-launchxl board. Has there been any updates/progress on this issue?

#6

I am having the same issue. I am using the mos.exe tool on Windows with the TI CC3220SF-LaunchXL. I have run the following commands:

mos clone https://github.com/mongoose-os-apps/empty
mos build --platform cc3220
mos flash

But, I still get this error. Please fix

#7

I was able to fix my error by installing a different version of Uniflash.
Uniflash v5.1.0 and v4.5.0 gave me the error above. But, v4.2.2 (available for Windows, Mac, and Linux from http://processors.wiki.ti.com/index.php/Category:CCS_UniFlash_Release_Notes_Archive) worked!

I wish the error codes were clearer about this issue. mos.exe has a detailed error code if you use Uniflash v.3 or do not have Uniflash installed which tells you to use Uniflash v4. But, since v4.5.0 did not work for me, this error code ought to be made more specific.